Error message

  • Warning: array_slice() expects parameter 1 to be array, null given in tikal_meetup_events() (line 194 of /opt/tikal/htdocs/prd/sites/all/modules/custom/tikal_meetup/tikal_meetup.module).
  • Warning: Invalid argument supplied for foreach() in include() (line 7 of /opt/tikal/htdocs/prd/sites/all/modules/custom/tikal_meetup/article_pages_events.tpl.php).

I want to change a plugin in RCP product, but to keep the old plugin alive.

A user can choose between plugin A or B using a configuration.

I thought about creating a new version for the plugin and switch between them according to a flag. The new version will be the default one.

The question is how can I 'downgrade' the plugin in order to get back to the old one if requested?