Flex file does not load when using SSL

Hi all,

 

I wrote a flex application, using BlazeDS that was working just fine.

 

Then I was asked to change my server to work with SSL.

 

After I changed the server settings to run with SSL, the flex file just refuses to load, without any error.

 

I started digging around and found some people who had the same problem and found a solution.

 

I followed this article: http://blog.crankybit.com/flex-remoting-over-ssl/ but the solution did not work for me.

 

In one of the forums, they recommended to install some kind of sniffer, and I installed IEWatch (http://www.iewatch.com/downloadie.aspx),

where I found out that the GET request for the swf file gets an error back:

Method: GET

Status: (ERROR_INTERNET_UNABLE_TO_CACHE_FILE)

URL: https://localhost:8443/cf-dashboard

 

 

I also noticed that even though I’ve added the : <add-no-cache-headers>false</add-no-cache-headers>

 

The HTTP response header still contained this:

Pragma:  No-cache
Cache-Control:  no-cache

 

When reviewing this: http://old.nabble.com/flex-application-is-not-loading-under-HTTPS-td19790768.html , I found this link: http://support.microsoft.com/kb/323308

Made the required changes in the registry and ta-da! It works!

 

The problem is, my application is deployed in a very large bank, and it will probably not be easy to convince them to change the registry for all their employees :(

 

Does anyone have any other suggestion/solution?

Thank you for your interest!

We will contact you as soon as possible.

Send us a message

Oops, something went wrong
Please try again or contact us by email at info@tikalk.com