Problem reporting event to Syslog with Log4j

Did anybody tried this ?

I have configured the Log4j to write to Syslog. Syslog service is up and running, but nothing is printed into syslog.

Here is my log4j.xml

<?xml version="1.0" encoding="UTF-8" ?>
<!DOCTYPE log4j:configuration SYSTEM "log4j.dtd">

<log4j:configuration xmlns:log4j="http://jakarta.apache.org/log4j/">

<appender name="syslog" class="org.apache.log4j.net.SyslogAppender">
     <param name="SyslogHost" value="127.0.0.1"/>
     <param name="Facility" value="USER"/>
    <param name="Threshold" value="INFO"/>
     <param name="FacilityPrinting" value="true"/>
     <layout class="org.apache.log4j.PatternLayout">
         <param name="ConversionPattern" value="%t %5r %-5p %-21d{yyyyMMdd [HH]mm:ss,SSS} %c{2} [%x] %m %n"/>
     </layout>
</appender>
 
  <appender name="console" class="org.apache.log4j.ConsoleAppender">
    <param name="Target" value="System.out"/>
    <param name="Threshold" value="INFO"/>
    <layout class="org.apache.log4j.PatternLayout">
      <param name="ConversionPattern" value="%-5p %t %c{1} - %m%n"/>
    </layout>
  </appender>

  <logger name="com.clearforest">
    <level value="INFO"/>
    <appender-ref ref="syslog" />
    <appender-ref ref="console" />
  </logger>

  <root>
    <level value="info"/>
    <appender-ref ref="syslog" />
  </root>
</log4j:configuration>

Thank you for your interest!

We will contact you as soon as possible.

Send us a message

Oops, something went wrong
Please try again or contact us by email at info@tikalk.com